EnderUNIX Team.


EnderUNIX İpucu

Arkadaşıma gönder , Ana Sayfa

[ antivirüs ]

"f-prot hataları -1" - Mesut GÜLNAZ - (2004-10-04 19:32:53)   [3861]

f-prot u kurduğunuz zaman qmail üzerinde kullanmak için bir perl scripti olan ve genellikle /usr/local/f-prot/tools dizini altında bulunan scan-mail.pl dosyasını
#./scan-mail.pl -daemon -server
modda çalıştırmanız gerekli böylelikle gelen mail daha önceden f-prot-qmail dosyası tarafından kabul edilerek bu script yardımı ile açılır taranır ve kapatılarak gerçek kuyruğa atılır.
bu script perl 5.6 ve üzerini kullanıyor. önerilen ise 5.8 versiyonu.
#./scan-mail.pl -daemon -server dediğinizde
Can't locate bytes.pm in @INC (@INC contains: /usr/local/lib/perl5/site_perl/5.005/i386-freebsd /usr/local/lib/perl5/site_perl/5.005 . /usr/libdata/perl/5.00503/mach /usr/libdata/perl/5.00503 /usr/local/f-prot/perllib) at /usr/local/f-prot/perllib/Anomy/MIMEStream.pm line 84.
BEGIN failed--compilation aborted at /usr/local/f-prot/perllib/Anomy/MIMEStream.pm line 84.
BEGIN failed--compilation aborted at /usr/local/f-prot/perllib/Anomy/Sanitizer.pm line 45.
BEGIN failed--compilation aborted at ./scan-mail.pl line 113.
su-2.05b#
gibi bir hata alırsanız bunun nedeni söz konusu scriptin hala eski olan perl 5.0 versiyonunu kullanmaya çalışmasından kaynaklanmaktadır. ve eğer sisteminizde perl 5.6 veya 5.8 kurulu ise sistemdeki perl scriplerinin artık yeni perl versiyonunu kullanmalarını söylemenizdir. bunun için vermeniz gereken komut

# use.perl port

olay bu kadar!

bunu yaptıktan sonra eğer sisteminizde gerekli diğer moduller kurulu ise
#./scan-mail.pl -daemon -server dediğinizde artık sorunsuz bir şekilde
# (consola) düşeceksiniz!

anlamak için ise
#sockstat -l

iyi çalışmalar!

Arkadaşıma gönder , Ana Sayfa